A collecting forum. CollectingBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » CollectingBanter forum » Collecting newsgroups
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Post New Thread
Threads in Forum : Juke Boxes Forum Tools Search this Forum Feed Icon
  Thread / Thread Starter Last Post Reverse Sort Order Replies Views
AMI E JUNCTION BOX TRANSFORMER by em pinball
I was working on my ami e-120 when i shorted the credit light out. blew a fuse. replaced fuse and when i plugged it in the transformer started to smoke. besides my stupidity can someone tell me what would cause the transformer to smoke. i have another transformer that shows 36 volts coming out of...
January 29th 11 01:22 PM
by em pinball Go to last post
2 845
my ami e-120 seems to be baxkwards by em pinball
my transformer went out. replaced it as well as the rectifier. noticed the cable from the carriage box to the junction block had a bunch of bad wires so replaced it with a good one. when i turn it on the record platter turns. all fuses looks okay. funny thing is if i push one of the selector pins...
January 29th 11 01:19 PM
by em pinball Go to last post
2 466
Exclamation
Help with Rock-Ola 473 by ECET3
Hello, we are three guys who are currently working on a Rock-Ola Jukebox (number 473) in school. We have never done this before. Everything is working fine, except the arm that changes the record. It works when it puts down the record, but when it tries to bring it back it makes a twitching...
January 26th 11 12:58 PM
by ECET3 Go to last post
2 340
nsm city IV by linemancriss
I have a nsm city IV that was my dads. would like to get it going again. can someone please help me.. when i try to play a song the player goes to the left and when it gets to the far left it make a couple of clicking sounds the gives a error 60. it will not go to the right. for some reason it does...
January 24th 11 01:46 PM
by philco Go to last post
5 1,730
FOR SALE : WURLITZER P-10 New York by Dave Beck
Hello fellas - I've had this sitting around for awhile, and now I've decided to sell it. It's as found condition. Decent cabinet. Complete. Even has the original coin box and back door. Amp has been rebuilt w/ new tubes. Everything else needs to be redone. Comes with both operating and parts...
January 23rd 11 09:21 PM
by Dave Beck Go to last post
1 1,273
wurlitzer 2500 33 rpm problem by mario p
hi, I have a 164 kit installed in my 2500, but it will only play 33 rpm records at 45 rpm speed. 45's play fine. Any ideas?
January 20th 11 07:47 PM
by Bob Raney Go to last post
2 596
looking for ami jukeboxes by em pinball
I am still looking for ami jukeboxes. models C, D-80, E-80-120, G-80-200. Looking for jukeboxes that needs work. also buying parts boxes. im located in missouri so hopefully not to far away. thanks for reading. norm
January 20th 11 02:01 PM
by em pinball Go to last post
0 1,350
NSM Satellite 200 by fubarcoin
Hello everybody, I am a juke box collector from Italy and have a couple of non working NSM Satellite jukes. They both accept the selected record, pick it up but then cancel it immediately. It seems the problems is caused by blown VARISTORS inside the Control unit.As I can't find such parts among...
January 20th 11 11:05 AM
by Alan Hood Go to last post
2 933
NSM Prestige es160 by Mark
Hello, New to this newsgroup. I bought a nonworking es160 at the St Louis superauctions yesterday. I was wondering if anyone has a copy of the service manual or schematics for this jukebox. I have already found the 5v regulator shorted so I hope this solves the problem, but I would like to have...
January 20th 11 11:01 AM
by Alan Hood Go to last post
3 2,550
Shyvers Multiphone by beb
I am interested in purchasing a Shyvers Multiphone. Only interested in one with all parts and in fairly good condition. Also, does anyone know of a wallbox that works with the Rockola DE 39? Thanks.
January 19th 11 07:44 PM
by beb Go to last post
0 1,030
NSM City 2 carriage unresponsive by James Prince
I recently was asked to look at an NSM City 2 for a friend. They said it was functioning properly until a few days ago when the carriage suddenly stopped responding. Apparently some mice were making a nest in it recently. I took a look at it to see if any wires were obviously chewed through, and...
January 19th 11 02:45 AM
by wescoles Go to last post
2 707
Florida Jukebox Repair by Jack
I just moved from NY to FL and my AMI "I" jukebox suddenly decided to stop returning the tonearm at the end of a 45. Anybody have any ideas or know of a reputable jukebox repair person in the Orlando/Melbourne area? Thanks! Jack
January 17th 11 01:52 PM
by Tonily Go to last post
1 1,956
record arm not working by [email protected]
ami coil for a and b side of record not working
January 17th 11 11:42 AM
by Alan Hood Go to last post
3 393
Rockola1468-record doesn't eject by smazik
I just got a rockola 1468 Tempo and it's working well except for occasionally when the record gets to the end, it keeps spinning and I have to open up the top and manually nudge the arm to get it to eject. Any help on how to solve this problem or what it could be?
January 16th 11 12:18 AM
by Rob in NYC[_2_] Go to last post
2 412
Rowe Ti-1 select coil locking on by Ron Lyons
Hi folks; I was wondering if somebody might help me figure out what's going on with my Jukebox. I have a Ti-1... it works pretty good, but lately I've been getting an issue where one of the select coils locks on. I usually won't realize it's done it until the record starts playing over and over...
January 15th 11 10:04 PM
by Oldtimejuker Go to last post
2 450
Seeburg usc1 1st digit not working by Tim[_4_]
Seeburg usc1 1st digit not working.When I make the first digit selection,the 1st digit light does not come on.When I select the second digit,the 2nd digit light comes on. It's apparently not the light itself,but in the circuit that runs that light.I've looked at wiring and see no problem.Just...
January 15th 11 08:53 AM
by azerty Go to last post
1 351
Rowe CD-100, its got me stumped!! by andrew96
Hi hopefully someone out there can help me! My CD100 just comes up with error 05-62, decoder board communication failure, now this is the odd bit, all the voltages to the mech board are present and correct, and if i put the whole mech and the ccc board, into a hcd-1 hideaway it all works...
(Multi-page thread 1 2)
January 15th 11 12:29 AM
by kreed Go to last post
10 1,284
wtb: rockola 1464 amp by cjkelly025
Evening, I just picked this one up last week and it had an amp and such in a box gave it a brief look over and called it good and loaded it up. I started messing with it yesterday and have everything else going right and go to grab the amp out of the box and low and behold it is not even in the...
January 15th 11 12:03 AM
by cjkelly025 Go to last post
4 584
Ami E 120 by wendlandt
I picked up an AMI E120 the other day and am having selector problems with it. I have cleaned all the push button selector contacts and the credit unit. None of the push buttons will make a selection. I have the manual, but it is a little hard to tell if I have the plugs in the correct position....
January 14th 11 09:27 PM
by Tim[_4_] Go to last post
2 760
seeburg L100 worth 1100.00 by Bob427
I have a chance to buy a fully working seeburg L it plays really nice and is in pretty good condition is it worth 1100.00 thanks Bob
January 13th 11 01:30 AM
by Tim[_4_] Go to last post
2 413
Post New Thread


Display Options
Showing threads 1001 to 1020 of 7197
Sorted By Sort Order
From The
Forum Tools Search this Forum
Search this Forum :

Advanced Search

New posts New posts More than 15 replies or 150 views Hot thread with new posts
No new posts No new posts More than 15 replies or 150 views Hot thread with no new posts
Closed Thread Thread is closed  
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 11:49 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2004-2020 CollectingBanter.
The comments are property of their posters.